Quantcast

[ jEdit-users ] Sessions: None

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[ jEdit-users ] Sessions: None

maxwell
Back in Feb 2015, I started a thread about the Sessions plugin:

http://jedit.9.x6.nabble.com/jEdit-users-jEdit-Sessions-plugin-td5005969.html

I mentioned back then that jEdit often started up with "Sessions: None"
at the top, even though it had in fact restored a saved session.  At the
time, I attributed this to version 1.5.1 of the Sessions plugin; when
you updated that plugin to 1.6.1, I thought this problem went away.
Unfortunately, it did not.

I'm not sure how to reliably trigger this buglet.  When I opened a
session in jEdit and closed and re-opened jEdit just now, it came back
with the previous session, as expected.  However, the experimental
"Sessions: Properties" dialog still thought it was "Session: None"; when
I then used the Sessions Manager to (re-)load that same session, then
called up the "Sessions: Properties" dialog, the dialog correctly
identified the session.

I'd be happy to submit a bug report (which I think would have a fairly
low priority), but as I say I don't know how to reliably trigger the
problem.  (I have however seen it on both my home computer an my
computer at work.)  Has anyone else seen this, and if so, do you know
how to trigger it?

jEdit v5.3.0, Sessions plugin v1.6.1, Windows 7.

    Mike Maxwell

------------------------------------------------------------------------------
--
-----------------------------------------------
jEdit Users' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [ jEdit-users ] Sessions: None

Alan Ezust-3
Administrator
I am overdue to release a newer Sessions. Please try a pre-release of it here:

https://dl.dropboxusercontent.com/u/31527080/Sessions.jar

It has plugin patch # 180 already applied. Perhaps that addresses some of your issues.
If not, perhaps you should contact Edward Diener about it, since he is the most recent person to work on it.



On Sat, Nov 26, 2016 at 9:14 PM, maxwell <[hidden email]> wrote:
Back in Feb 2015, I started a thread about the Sessions plugin:

http://jedit.9.x6.nabble.com/jEdit-users-jEdit-Sessions-plugin-td5005969.html

I mentioned back then that jEdit often started up with "Sessions: None"
at the top, even though it had in fact restored a saved session.  At the
time, I attributed this to version 1.5.1 of the Sessions plugin; when
you updated that plugin to 1.6.1, I thought this problem went away.
Unfortunately, it did not.

I'm not sure how to reliably trigger this buglet.  When I opened a
session in jEdit and closed and re-opened jEdit just now, it came back
with the previous session, as expected.  However, the experimental
"Sessions: Properties" dialog still thought it was "Session: None"; when
I then used the Sessions Manager to (re-)load that same session, then
called up the "Sessions: Properties" dialog, the dialog correctly
identified the session.

I'd be happy to submit a bug report (which I think would have a fairly
low priority), but as I say I don't know how to reliably trigger the
problem.  (I have however seen it on both my home computer an my
computer at work.)  Has anyone else seen this, and if so, do you know
how to trigger it?

jEdit v5.3.0, Sessions plugin v1.6.1, Windows 7.

    Mike Maxwell

------------------------------------------------------------------------------
--
-----------------------------------------------
jEdit Users' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-users


------------------------------------------------------------------------------

--
-----------------------------------------------
jEdit Users' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-users
Loading...