[ jEdit-users ] Can't upgrade jEdit

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[ jEdit-users ] Can't upgrade jEdit

Jim Byrnes-4
Is the info on this page http://www.jedit.org/index.php?page=download 
regarding Ubuntu users still valid?  I have been trying to upgrade from
5.1 to 5.3 but get the following errors.

Reading package lists... Done
W: Failed to fetch
http://switch.dl.sourceforge.net/project/jedit/InRelease

W: Failed to fetch
http://switch.dl.sourceforge.net/project/jedit/Release.gpg  Could not
resolve 'switch.dl.sourceforge.net'

W: Some index files failed to download. They have been ignored, or old
ones used instead.

Thanks,  Jim

------------------------------------------------------------------------------
What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
patterns at an interface-level. Reveals which users, apps, and protocols are
consuming the most bandwidth. Provides multi-vendor support for NetFlow,
J-Flow, sFlow and other flows. Make informed decisions using capacity
planning reports. http://sdm.link/zohodev2dev
--
-----------------------------------------------
jEdit Users' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [ jEdit-users ] Can't upgrade jEdit

Dale Anson-3
Hi Jim,

I'm not running Ubuntu anymore, so I can't test this specific issue, but you could download the .deb file manually and install it by hand.  You can install it using sudo dpkg -i /path/to/deb/file followed by sudo apt-get install -f. As I said, I don't have Ubuntu anymore, but this should work.

Another option is to download the java installer, which works on any platform. The downside is the apt database won't know about it.

Dale



On Mon, Sep 12, 2016 at 3:49 PM, Jim Byrnes <[hidden email]> wrote:
Is the info on this page http://www.jedit.org/index.php?page=download
regarding Ubuntu users still valid?  I have been trying to upgrade from
5.1 to 5.3 but get the following errors.

Reading package lists... Done
W: Failed to fetch
http://switch.dl.sourceforge.net/project/jedit/InRelease

W: Failed to fetch
http://switch.dl.sourceforge.net/project/jedit/Release.gpg  Could not
resolve 'switch.dl.sourceforge.net'

W: Some index files failed to download. They have been ignored, or old
ones used instead.

Thanks,  Jim

------------------------------------------------------------------------------
What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
patterns at an interface-level. Reveals which users, apps, and protocols are
consuming the most bandwidth. Provides multi-vendor support for NetFlow,
J-Flow, sFlow and other flows. Make informed decisions using capacity
planning reports. http://sdm.link/zohodev2dev
--
-----------------------------------------------
jEdit Users' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-users


------------------------------------------------------------------------------

--
-----------------------------------------------
jEdit Users' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [ jEdit-users ] Can't upgrade jEdit

Andrew Sowerby
In reply to this post by Jim Byrnes-4
Hi Jim, 

The errors say that it can't resolve 
I tried hitting those URLs from a browser on my smartphone and I get a 404.


Reading package lists... Done
W: Failed to fetch
http://switch.dl.sourceforge.net/project/jedit/InRelease

W: Failed to fetch
http://switch.dl.sourceforge.net/project/jedit/Release.gpg  Could not
resolve 'switch.dl.sourceforge.net'

Where the instructions say :

>>
.. add the following line to your /etc/apt/sources.list:

deb http://<mirror>.dl.sourceforge.net/project/jedit /

e. g.

deb http://switch.dl.sourceforge.net/project/jedit /
<<

I assume you can choose a different mirror. 'switch.dl.sourceforge.net' is either temporarily down, or decommissioned. 

Where the list of mirrors is, I don't know, but "heanet.dl.sourceforge.net" is up and works for me. Some others, like aarnet, jaist and kent don't seem to work. 

Heanet is pretty reliable, but unless you're based in Ireland, it probably won't be the quickest one for you. 
--

_Andrew_


------------------------------------------------------------------------------

--
-----------------------------------------------
jEdit Users' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-users
Loading...