Quantcast

[ jEdit-devel ] xml/html completion not working

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[ jEdit-devel ] xml/html completion not working

Alan Ezust-3
Administrator
I noticed with my current trunk versions of sidekick+xml, I don't get completions, and even for the </ that is set for the XML general settings. Is it working fine for others?



------------------------------------------------------------------------------

--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [ jEdit-devel ] xml/html completion not working

Eric Le Lay
Administrator
Le Thu, 22 Sep 2016 17:44:20 -0700,
Alan Ezust <[hidden email]> a écrit :

> I noticed with my current trunk versions of sidekick+xml, I don't get
> completions, and even for the </ that is set for the XML general
> settings. Is it working fine for others?

It works for me (tested with xml plugin manual, inserting '<' under
the last <author> in the <authorgroup>).

------------------------------------------------------------------------------
--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [ jEdit-devel ] xml/html completion not working

Alan Ezust-3
Administrator
Weird, I am debugging it now. It keeps returning from SideKickActions.java:114

        // check if user wants completion for this mode
        if (!jEdit.getBooleanProperty("mode." + bufferMode.getName() + ".sidekick.completion", false))
            return;

So it thinks  "user does not want completion" for this mode. But I do want completion!!
I can't find that property anywhere in my properties file.
Is there a setting I need to change in plugin options somewhere?




On Fri, Sep 23, 2016 at 12:26 AM, Eric Le Lay <[hidden email]> wrote:
Le Thu, 22 Sep 2016 17:44:20 -0700,
Alan Ezust <[hidden email]> a écrit :

> I noticed with my current trunk versions of sidekick+xml, I don't get
> completions, and even for the </ that is set for the XML general
> settings. Is it working fine for others?

It works for me (tested with xml plugin manual, inserting '<' under
the last <author> in the <authorgroup>).


------------------------------------------------------------------------------

--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [ jEdit-devel ] xml/html completion not working

Alan Ezust-3
Administrator
Aha I see the new "completion" checkbox in the parser options pane now.
So I guess that property needs to be enabled by default for Java, XML and whatever other parsers offer completion?


On Fri, Sep 30, 2016 at 9:13 AM, Alan Ezust <[hidden email]> wrote:
Weird, I am debugging it now. It keeps returning from SideKickActions.java:114

        // check if user wants completion for this mode
        if (!jEdit.getBooleanProperty("mode." + bufferMode.getName() + ".sidekick.completion", false))
            return;

So it thinks  "user does not want completion" for this mode. But I do want completion!!
I can't find that property anywhere in my properties file.
Is there a setting I need to change in plugin options somewhere?




On Fri, Sep 23, 2016 at 12:26 AM, Eric Le Lay <[hidden email]> wrote:
Le Thu, 22 Sep 2016 17:44:20 -0700,
Alan Ezust <[hidden email]> a écrit :

> I noticed with my current trunk versions of sidekick+xml, I don't get
> completions, and even for the </ that is set for the XML general
> settings. Is it working fine for others?

It works for me (tested with xml plugin manual, inserting '<' under
the last <author> in the <authorgroup>).



------------------------------------------------------------------------------

--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [ jEdit-devel ] xml/html completion not working

Alan Ezust-3
Administrator
Shouldn't the default be "true" rather than "false" ?
Why would people want it off by default?

------------------------------------------------------------------------------

--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [ jEdit-devel ] xml/html completion not working

Dale Anson-3

It should be off by default since completion is more annoying than useful :) just my opinion, of course.


On Sep 30, 2016 10:34 AM, "Alan Ezust" <[hidden email]> wrote:
Shouldn't the default be "true" rather than "false" ?
Why would people want it off by default?

------------------------------------------------------------------------------

--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel
Loading...