[ jEdit-devel ] newbie build error

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[ jEdit-devel ] newbie build error

Nick Hilton
Hi all.

I just checkout trunk from svn:

    # ...
    Checked out revision 24599

and when I build with ant, I get unresolved dependencies.

    [ivy:retrieve] :: problems summary ::
    [ivy:retrieve] :::: WARNINGS
    [ivy:retrieve] module not found: org.jedit.plugins#MacOSX;1.3
    [ivy:retrieve] ==== jedit-plugins: tried
    [ivy:retrieve]  -- artifact org.jedit.plugins#MacOSX;1.3!MacOSX.jar:
    [ivy:retrieve] module not found: org.jedit.plugins#QuickNotepad;5.0
    [ivy:retrieve] ==== jedit-plugins: tried
    [ivy:retrieve]  -- artifact org.jedit.plugins#QuickNotepad;5.0!QuickNotepad.jar:
    [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:retrieve] ::          UNRESOLVED DEPENDENCIES         ::
    [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:retrieve] :: org.jedit.plugins#MacOSX;1.3: not found
    [ivy:retrieve] :: org.jedit.plugins#QuickNotepad;5.0: not found
    [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:retrieve] 
    [ivy:retrieve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
    
    BUILD FAILED
    /home/nhilton/development/jedit/jedit_ws/build.xml:124: impossible to resolve dependencies:
        resolve failed - see output for details

Clearing out the ivy cache dir did not resolve the issue:

    rm -rf ~/.ivy2/cache
    ant

I'm on ubuntu 16, I don't know how to proceed.  Any tips?

Thanks!
Nick

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel
Reply | Threaded
Open this post in threaded view
|

Re: [ jEdit-devel ] newbie build error

Alan Ezust-3
Administrator
Hi Nick,

I do not know what the problem is yet since i did not set up these ivy repositories,
but I have the same problem on my end, so it's not a newbie problem at all, and affects all of us.

--Alan



On Sat, Feb 4, 2017 at 10:00 AM, Nick Hilton <[hidden email]> wrote:
Hi all.

I just checkout trunk from svn:

    # ...
    Checked out revision 24599

and when I build with ant, I get unresolved dependencies.

    [ivy:retrieve] :: problems summary ::
    [ivy:retrieve] :::: WARNINGS
    [ivy:retrieve] module not found: org.jedit.plugins#MacOSX;1.3
    [ivy:retrieve] ==== jedit-plugins: tried
    [ivy:retrieve]  -- artifact org.jedit.plugins#MacOSX;1.3!MacOSX.jar:
    [ivy:retrieve] module not found: org.jedit.plugins#QuickNotepad;5.0
    [ivy:retrieve] ==== jedit-plugins: tried
    [ivy:retrieve]  -- artifact org.jedit.plugins#QuickNotepad;5.0!QuickNotepad.jar:
    [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:retrieve] ::          UNRESOLVED DEPENDENCIES         ::
    [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:retrieve] :: org.jedit.plugins#MacOSX;1.3: not found
    [ivy:retrieve] :: org.jedit.plugins#QuickNotepad;5.0: not found
    [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:retrieve] 
    [ivy:retrieve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
    
    BUILD FAILED
    /home/nhilton/development/jedit/jedit_ws/build.xml:124: impossible to resolve dependencies:
        resolve failed - see output for details

Clearing out the ivy cache dir did not resolve the issue:

    rm -rf ~/.ivy2/cache
    ant

I'm on ubuntu 16, I don't know how to proceed.  Any tips?

Thanks!
Nick

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel
Reply | Threaded
Open this post in threaded view
|

Re: [ jEdit-devel ] newbie build error

Björn Kautler
Hi,

it works again now.
It is the same problem that hit us in the plugin manager.
Standard Java URL handling intentionally does not follow HTTP redirects across protocols.
SourceForge changed their forwarding at some point so that you are always forwarded to HTTPS.
This redirect was not followed and thus the whole machinery did not work properly.
I changed the Ivy setup so that now our list of mirrors is retrieved and inserted into the settings file individually.

Cheers
Björn



2017-02-04 20:31 GMT+01:00 Alan Ezust <[hidden email]>:
Hi Nick,

I do not know what the problem is yet since i did not set up these ivy repositories,
but I have the same problem on my end, so it's not a newbie problem at all, and affects all of us.

--Alan



On Sat, Feb 4, 2017 at 10:00 AM, Nick Hilton <[hidden email]> wrote:
Hi all.

I just checkout trunk from svn:

    # ...
    Checked out revision 24599

and when I build with ant, I get unresolved dependencies.

    [ivy:retrieve] :: problems summary ::
    [ivy:retrieve] :::: WARNINGS
    [ivy:retrieve] module not found: org.jedit.plugins#MacOSX;1.3
    [ivy:retrieve] ==== jedit-plugins: tried
    [ivy:retrieve]  -- artifact org.jedit.plugins#MacOSX;1.3!MacOSX.jar:
    [ivy:retrieve] module not found: org.jedit.plugins#QuickNotepad;5.0
    [ivy:retrieve] ==== jedit-plugins: tried
    [ivy:retrieve]  -- artifact org.jedit.plugins#QuickNotepad;5.0!QuickNotepad.jar:
    [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:retrieve] ::          UNRESOLVED DEPENDENCIES         ::
    [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:retrieve] :: org.jedit.plugins#MacOSX;1.3: not found
    [ivy:retrieve] :: org.jedit.plugins#QuickNotepad;5.0: not found
    [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:retrieve] 
    [ivy:retrieve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
    
    BUILD FAILED
    /home/nhilton/development/jedit/jedit_ws/build.xml:124: impossible to resolve dependencies:
        resolve failed - see output for details

Clearing out the ivy cache dir did not resolve the issue:

    rm -rf ~/.ivy2/cache
    ant

I'm on ubuntu 16, I don't know how to proceed.  Any tips?

Thanks!
Nick

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel