[ jEdit-devel ] [jedit:plugin-central-submission] #1019 JSLinters 0.1.0

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[ jEdit-devel ] [jedit:plugin-central-submission] #1019 JSLinters 0.1.0

Eric Le Lay-2

[plugin-central-submission:#1019] JSLinters 0.1.0

Status: open
Group: None
Created: Mon Sep 12, 2016 02:28 PM UTC by Eric Le Lay
Last Updated: Mon Sep 12, 2016 02:28 PM UTC
Owner: nobody

{{{ JSLinters 0.1.0
Source: Source code is in git with the tag 0.1.0
Announcement: First release!
Requires Java 1.8
Requires jEdit 05.03.00.00
Required plugins:
ErrorList 2.3 (errorlist.ErrorListPlugin)

Short Description: The JSLinters plugin provides validation for javascript using jshint and eslint.

Long Description: <html>
<p>The JSLinters plugin lets you run JavaScript code checkers
JSHint (<a href="http://jshint.com">http://jshint.com</a>) or
ESLint (<a href="http://eslint.org">http://eslint.org</a>) in jEdit
and shows errors in ErrorList.</p>

<p>It can use the system's jshint or eslint (node.js executable)
or install and run jshint in the JVM without dependencies.</p>

</html>

}}}


Sent from sourceforge.net because [hidden email] is subscribed to https://sourceforge.net/p/jedit/plugin-central-submission/

To unsubscribe from further messages, a project admin can change settings at https://sourceforge.net/p/jedit/admin/plugin-central-submission/options. Or, if this is a mailing list, you can unsubscribe from the mailing list.


------------------------------------------------------------------------------

--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel
Reply | Threaded
Open this post in threaded view
|

[ jEdit-devel ] [jedit:plugin-central-submission] #1019 JSLinters 0.1.0

Eric Le Lay-2
  • Description has changed:

Diff:

--- old
+++ new
@@ -1,5 +1,5 @@
 {{{ JSLinters 0.1.0
-    Source: Source code is in git with the tag 0.1.0
+    Source: Source code is in git with the tag 0.1.0_1
     Announcement: First release!
     Requires Java 1.8
     Requires jEdit 05.03.00.00
  • Comment:

I've re-tagged: it's 0.1.0_1 now.


[plugin-central-submission:#1019] JSLinters 0.1.0

Status: open
Group: None
Created: Mon Sep 12, 2016 02:28 PM UTC by Eric Le Lay
Last Updated: Mon Sep 12, 2016 02:28 PM UTC
Owner: nobody

{{{ JSLinters 0.1.0
Source: Source code is in git with the tag 0.1.0_1
Announcement: First release!
Requires Java 1.8
Requires jEdit 05.03.00.00
Required plugins:
ErrorList 2.3 (errorlist.ErrorListPlugin)

Short Description: The JSLinters plugin provides validation for javascript using jshint and eslint.

Long Description: <html>
<p>The JSLinters plugin lets you run JavaScript code checkers
JSHint (<a href="http://jshint.com">http://jshint.com</a>) or
ESLint (<a href="http://eslint.org">http://eslint.org</a>) in jEdit
and shows errors in ErrorList.</p>

<p>It can use the system's jshint or eslint (node.js executable)
or install and run jshint in the JVM without dependencies.</p>

</html>

}}}


Sent from sourceforge.net because [hidden email] is subscribed to https://sourceforge.net/p/jedit/plugin-central-submission/

To unsubscribe from further messages, a project admin can change settings at https://sourceforge.net/p/jedit/admin/plugin-central-submission/options. Or, if this is a mailing list, you can unsubscribe from the mailing list.


------------------------------------------------------------------------------

--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel
Reply | Threaded
Open this post in threaded view
|

[ jEdit-devel ] [jedit:plugin-central-submission] #1019 JSLinters 0.1.0

Townsfolk
In reply to this post by Eric Le Lay-2
  • status: open --> pending
  • assigned_to: Townsfolk
  • Comment:

Eric, I'm waiting on this one because we don't have jdk 1.8 support in the plugin wizard yet.

I compiled, tested, and uploaded it to plugin central, but it won't be available in Plugin Manager until we add 1.8.

I'll close it as soon as that happens.


[plugin-central-submission:#1019] JSLinters 0.1.0

Status: pending
Group: None
Created: Mon Sep 12, 2016 02:28 PM UTC by Eric Le Lay
Last Updated: Fri Sep 16, 2016 02:48 PM UTC
Owner: Townsfolk

{{{ JSLinters 0.1.0
Source: Source code is in git with the tag 0.1.0_1
Announcement: First release!
Requires Java 1.8
Requires jEdit 05.03.00.00
Required plugins:
ErrorList 2.3 (errorlist.ErrorListPlugin)

Short Description: The JSLinters plugin provides validation for javascript using jshint and eslint.

Long Description: <html>
<p>The JSLinters plugin lets you run JavaScript code checkers
JSHint (<a href="http://jshint.com">http://jshint.com</a>) or
ESLint (<a href="http://eslint.org">http://eslint.org</a>) in jEdit
and shows errors in ErrorList.</p>

<p>It can use the system's jshint or eslint (node.js executable)
or install and run jshint in the JVM without dependencies.</p>

</html>

}}}


Sent from sourceforge.net because [hidden email] is subscribed to https://sourceforge.net/p/jedit/plugin-central-submission/

To unsubscribe from further messages, a project admin can change settings at https://sourceforge.net/p/jedit/admin/plugin-central-submission/options. Or, if this is a mailing list, you can unsubscribe from the mailing list.


------------------------------------------------------------------------------

--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel
Reply | Threaded
Open this post in threaded view
|

[ jEdit-devel ] [jedit:plugin-central-submission] #1019 JSLinters 0.1.0

Townsfolk
In reply to this post by Eric Le Lay-2
  • status: pending --> closed-accepted

[plugin-central-submission:#1019] JSLinters 0.1.0

Status: closed-accepted
Group: None
Created: Mon Sep 12, 2016 02:28 PM UTC by Eric Le Lay
Last Updated: Tue Nov 15, 2016 08:49 AM UTC
Owner: Townsfolk

{{{ JSLinters 0.1.0
Source: Source code is in git with the tag 0.1.0_1
Announcement: First release!
Requires Java 1.8
Requires jEdit 05.03.00.00
Required plugins:
ErrorList 2.3 (errorlist.ErrorListPlugin)

Short Description: The JSLinters plugin provides validation for javascript using jshint and eslint.

Long Description: <html>
<p>The JSLinters plugin lets you run JavaScript code checkers
JSHint (<a href="http://jshint.com">http://jshint.com</a>) or
ESLint (<a href="http://eslint.org">http://eslint.org</a>) in jEdit
and shows errors in ErrorList.</p>

<p>It can use the system's jshint or eslint (node.js executable)
or install and run jshint in the JVM without dependencies.</p>

</html>

}}}


Sent from sourceforge.net because [hidden email] is subscribed to https://sourceforge.net/p/jedit/plugin-central-submission/

To unsubscribe from further messages, a project admin can change settings at https://sourceforge.net/p/jedit/admin/plugin-central-submission/options. Or, if this is a mailing list, you can unsubscribe from the mailing list.


------------------------------------------------------------------------------

--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel