Quantcast

[ jEdit-devel ] [ jedit-Bugs-821845 ] Blocks of text disappear (syntax hilighting problem?)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[ jEdit-devel ] [ jedit-Bugs-821845 ] Blocks of text disappear (syntax hilighting problem?)

SourceForge.net
Bugs item #821845, was opened at 2003-10-11 19:30
Message generated for change (Comment added) made by vampire0
You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=100588&aid=821845&group_id=588

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: text area and syntax packages
Group: None
>Status: Pending
>Resolution: Out of Date
Priority: 5
Private: No
Submitted By: John Morris (dawktrrx)
Assigned to: Nobody/Anonymous (nobody)
Summary: Blocks of text disappear (syntax hilighting problem?)

Initial Comment:
I have had a problem for some time now with large blocks  
of text disappearing while I am editing. It is intermittent, not  
happening very often.  
 
Usually a line of text will be blank until a place where the  
code has a break in it. For example take the lines:  
 
DummyThread dummyThread = new DummyThread();  
dummyThread.start();  
 
when the error occurs, the screen might be painted like this:  
 
                         = new DummyThread();  
             start();  
 
This can happen over large areas, or to one line, all  
intermittently. Sometimes a reload helps, other times not.
Scrolling the screen sometimes helps but usually not.
 
I am using Mandrake linux 9.1 with Suns J2SDK 1.4.2 and
JEdit 4.2preX.  This has happened for the past several
weeks over several pre versions.
 
I have a couple of screen shots which show the a section of  
code correctly, and then when the error is occuring, I'll send
along the screen shot of the error so you can see it in action.
 
This screenshot also shows a couple of blocks (in some
remarks) that did manage to get redrawn partially, but this
is a rare occurance, usually the redraw doesn't happen.
 
 

----------------------------------------------------------------------

>Comment By: Björn Kautler (vampire0)
Date: 2006-11-13 15:03

Message:
Logged In: YES
user_id=918212

Does this still happen with 4.2final or even 4.3preX?

----------------------------------------------------------------------

Comment By: A. Bernard (aleaur)
Date: 2004-09-19 12:56

Message:
Logged In: YES
user_id=1124500

I just had the same sort of bug with jEdit 4.1 yesterday.
I haven't upgraded yet to 4.2 but I wondering if this bug is
corrected by now.

What I observed its that only blocks following /* have this
kind of problems. In my code it was when I indented a block
of commented lines (between /* and */) that this block
disappeared.
When I look the screenshot provided by dawktrrx I can see a
/* before the wrong lines.

----------------------------------------------------------------------

Comment By: Slava Pestov (spestov)
Date: 2003-12-23 02:01

Message:
Logged In: YES
user_id=2280

I saw similar bug the other day -- text was getting chunked
properly and widths and offset calculations were ok, but it
was not being painted! and copying and pasting the same text
to a new, text mode buffer would still show the same
problem. However restarting jEdit resolved it. Very odd.

----------------------------------------------------------------------

Comment By: John Morris (dawktrrx)
Date: 2003-10-17 19:28

Message:
Logged In: YES
user_id=279319

I don't believe this happened with 4.1.  I will have to
download a fresh copy of 4.1 and use it for a few days and
see if the same behavior occurs.

----------------------------------------------------------------------

Comment By: Slava Pestov (spestov)
Date: 2003-10-13 22:04

Message:
Logged In: YES
user_id=2280

Did this happen in jEdit 4.1?

----------------------------------------------------------------------

You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=100588&aid=821845&group_id=588

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel
Loading...