[ jEdit-devel ] Ant 1.9 is now required?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[ jEdit-devel ] Ant 1.9 is now required?

Dale Anson-3
Just curious, what is it in Ant 1.9 that makes it required to build jEdit?

Dale



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel
Reply | Threaded
Open this post in threaded view
|

Re: [ jEdit-devel ] Ant 1.9 is now required?

Dale Anson-3
And along with that, is Java 1.8 really required, or is it just updating things to the latest versions?

On Sun, Mar 26, 2017 at 4:23 PM, Dale Anson <[hidden email]> wrote:
Just curious, what is it in Ant 1.9 that makes it required to build jEdit?

Dale




------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel
Reply | Threaded
Open this post in threaded view
|

Re: [ jEdit-devel ] Ant 1.9 is now required?

Vampire-3
Administrator
Actually it was decided to drop the support for 2 years end-of-life Java 7 and depend on Java 8 now, making it also possible to use Java 8 language features in jEdit and plugins code. 

So yes, Java 8 is required now. 

This was also the cause for the needed upgrade of Ant, as the JDepend in Ant before 1.9 was not compatible with the new bytecodes that were introduced in Java 8.

Regards,
Björn

Am 27.03.2017 00:28 schrieb "Dale Anson" <[hidden email]>:
And along with that, is Java 1.8 really required, or is it just updating things to the latest versions?

On Sun, Mar 26, 2017 at 4:23 PM, Dale Anson <[hidden email]> wrote:
Just curious, what is it in Ant 1.9 that makes it required to build jEdit?

Dale




------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel
Reply | Threaded
Open this post in threaded view
|

Re: [ jEdit-devel ] Ant 1.9 is now required?

Dale Anson-3
Thanks! I don't have any problem with the changes, I guess I wasn't paying attention and didn't realize they were in the 5.4 release. I've been running Java 8 for quite a while and upgraded my Ant to 1.10.1 today.

On Sun, Mar 26, 2017 at 5:24 PM, Vampire <[hidden email]> wrote:
Actually it was decided to drop the support for 2 years end-of-life Java 7 and depend on Java 8 now, making it also possible to use Java 8 language features in jEdit and plugins code. 

So yes, Java 8 is required now. 

This was also the cause for the needed upgrade of Ant, as the JDepend in Ant before 1.9 was not compatible with the new bytecodes that were introduced in Java 8.

Regards,
Björn

Am 27.03.2017 00:28 schrieb "Dale Anson" <[hidden email]>:
And along with that, is Java 1.8 really required, or is it just updating things to the latest versions?

On Sun, Mar 26, 2017 at 4:23 PM, Dale Anson <[hidden email]> wrote:
Just curious, what is it in Ant 1.9 that makes it required to build jEdit?

Dale




------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
--
-----------------------------------------------
jEdit Developers' List
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jedit-devel